Site Tools


Hotfix release available: 2024-02-06a "Kaos". upgrade now! [55.1] (what's this?)
New release available: 2024-02-06 "Kaos". upgrade now! [55] (what's this?)
Hotfix release available: 2023-04-04a "Jack Jackrum". upgrade now! [54.1] (what's this?)
New release available: 2023-04-04 "Jack Jackrum". upgrade now! [54] (what's this?)
Hotfix release available: 2022-07-31b "Igor". upgrade now! [53.1] (what's this?)
Hotfix release available: 2022-07-31a "Igor". upgrade now! [53] (what's this?)
New release available: 2022-07-31 "Igor". upgrade now! [52.2] (what's this?)
New release candidate 2 available: rc2022-06-26 "Igor". upgrade now! [52.1] (what's this?)
New release candidate available: 2022-06-26 "Igor". upgrade now! [52] (what's this?)
Hotfix release available: 2020-07-29a "Hogfather". upgrade now! [51.4] (what's this?)
public:deploy:software_installation_configurations

Software Installation Configurations

Server Hardware and Software Requirements:

ExpertusONE Server Platform Version 1 (ESP1)

 A) Operating System: Redhat distro ( any OS with Redhat flavor) i386 or x64 bit, can also be in Windows Operating system which depends on our customers requirement.
 B) Apache:  Apache version 2.2.18 (should be installed with SSL support)
 C) Mysql: Mysql version 5.1.37
 D) PHP: PHP 5.2.6 – Basic Extensions needs to be enabled during installation: 
    ctype functions, cURL support, date/time support, DOM/XML, EXIF Support, Input Validation and Filtering, GD Support, Hash support, iconv support, Json support, 
    libXML support, Multibyte support, mcrypt support, MySQL support, Mysqli support, OpenSSL support, PCRE(Perl Compatible Regular Expressions) support, PDO support, 
    PDO Driver for MySQL, client library version, pDO Driver for SQLite 3.x, posix, Reflection, Session Support, Simplexml support, Soap support - Client and Server, 
    SPL support, SQLite support, Tokenizer support, XML support, XML Reader and Writer, XSL, Zip, Zlib support.
 E) Tomcat(for AMS): apache-tomcat-5.5.25
 F) Apache-Tomcat Connector: jakarta-tomcat-connectors-1.2.15
 Note:- Preferred installation location: /opt/ESP1/{mysql,apache,php,tomcat}
 

ExpertusONE Server Platform Version 2 (ESP2)

 A) Operating System: Redhat distro ( any OS with Redhat flavor) i386 or x64 bit, can also be in Windows Operating system which depends on our customers requirement.
 B) Apache:  Apache version 2.2.18 (should be installed with SSL support)
 C) Mysql: Mysql version 5.5.8
 D) PHP: PHP 5.3.5 – Basic Extensions needs to be enabled during installation: 
    ctype functions, cURL support, date/time support, DOM/XML, EXIF Support, Input Validation and Filtering, GD Support, Hash support, iconv support, Json support, 
    libXML support, Multibyte support, mcrypt support, MySQL support, Mysqli support, OpenSSL support, PCRE(Perl Compatible Regular Expressions) support, PDO support, 
    PDO Driver for MySQL, client library version, pDO Driver for SQLite 3.x, posix, Reflection, Session Support, Simplexml support, Soap support - Client and Server, 
    SPL support, SQLite support, Tokenizer support, XML support, XML Reader and Writer, XSL, Zip, Zlib support.
 E) Tomcat(for AMS): apache-tomcat-5.5.25
 F) Apache-Tomcat Connector: jakarta-tomcat-connectors-1.2.15
 G) Memcache setup for Apache. (libevent-1.4.9-stable, memcached-1.3.0)
    (reference for memcache installation, http://linuxwindowsmaster.com/how-to-install-memcache-on-linux-server/)
 H) APC setup for Apache. (APC-3.0.16)
    (reference for apc installation, http://www.electrictoolbox.com/install-apc-php-linux/)
 Note:- Preferred installation location: /opt/ESP2/{mysql,apache,php,tomcat}

Client Software Requirements:

 A) Web Browser Supported: Internet Explorer (IE) v7 and above , FireFox v3 and above

Prabhu 2011/02/25 10:59

public/deploy/software_installation_configurations.txt · Last modified: 2022/06/14 10:16 (external edit)